Help - Please if you can :)

Go down

Help - Please if you can :)

Post by Guest on Sun Aug 16, 2009 2:57 pm

Hi all,
I have been having a few problems with my Corsa which is a 2002reg SRI 1.2 petrol,
I recently took a quite lenghty motorway journey and all was going well until I needed to over take, bearing in mind I was probably already doing about 50 -60mph but when It came to accellerating the car seemed to take some effort to reach 70mph, why could this be?
I ended up slowing the traffic down because it took me so long to get a good speed quite frightening when you think about it.
Be greatfull of any help and advice
Trouble25 x

Guest
Guest


Back to top Go down

Re: Help - Please if you can :)

Post by Johnston_888 on Sun Aug 16, 2009 5:16 pm

Hmmm........I don't have a clue what could be the problem, could be fueling problems or it may be turbo failing

_________________

Keep the Faith
avatar
Johnston_888
Site Owner & Senior Admin
Site Owner & Senior Admin

Posts : 672
Reputation : 6
Join date : 2009-04-07
Location : Perth, Scotland

http://www.vx-uk.com

Back to top Go down

Re: Help - Please if you can :)

Post by Guest on Sun Aug 16, 2009 6:08 pm

Thanks for your reply and any help is better than none esp as im no expert on cars lol lol I did however make sure the car was fuelled up before leaving and ive also been using redex to clean out the systems but not sure how good these things actually work Smile
The car has recently had the coil and spark plugs done so I know it cnt be these but have no other clue to why this could be happening ggrrr. I have read on a few sites that power loss is a common problem but I'm not at all sure how true this is because surely if this was the case there would be a solution to it.

Thanks anyway if anyone else has any more advise id be very greatfull Smile

Guest
Guest


Back to top Go down

Re: Help - Please if you can :)

Post by Bugsy on Mon Aug 17, 2009 12:09 pm

I'll have a look for you think its same problem i had with my old car

Bugsy
Life
Life

Posts : 74
Reputation : 0
Join date : 2009-07-23
Age : 32
Location : A Gay Bar

Back to top Go down

Re: Help - Please if you can :)

Post by vinny_69 on Mon Aug 17, 2009 3:07 pm

did the eml warning light come on?
avatar
vinny_69
Life
Life

Posts : 146
Reputation : 3
Join date : 2009-05-31
Age : 37
Location : Luton

http://www.vq9.co.uk

Back to top Go down

Re: Help - Please if you can :)

Post by Kenobi on Tue Aug 18, 2009 1:36 pm

Firstly, its not a turbo is it so thats not the problem.

Secondly Loss of power trying to reach 70 sounds like an ignition problem. Im going with the idea one of you new coil packs has failed.

Are there any other signs ie jumpy, hesitation on acceleration does it kangaroo ect?

_________________
avatar
Kenobi
Admin
Admin

Posts : 206
Reputation : 4
Join date : 2009-04-08
Age : 39
Location : Leicestershire

http://www.htecelite.com

Back to top Go down

Re: Help - Please if you can :)

Post by playgirl on Sun Aug 23, 2009 1:08 am

:S are you sure its a SRI and not a SXI didnt think they did a 1.2 SRI thought they only did the SRI's in the 1.4 or the 1.8
and as for the problem could be the start of problems with the head gasett as when mine went on the SRI i lost loads of power i could have walked out and ran quicker, and when you start it up does it sound like a loud ticking sound ??????
avatar
playgirl
Promo Girls
Promo Girls

Posts : 100
Reputation : 3
Join date : 2009-05-06
Location : Hampshire

Back to top Go down

Re: Help - Please if you can :)

Post by Guest on Sun Aug 23, 2009 9:26 pm

This is pretty much the same problem as mine!

But to add to my problems my gear linkage snapped...AGAIN!!!!! 2 time in about 4 months!! GRRRRRRRRRRR

Guest
Guest


Back to top Go down

Re: Help - Please if you can :)

Post by VXR VIC on Mon Aug 31, 2009 11:57 pm

could be airflow meter, coil pack, spark plug, fuel pump. did eml light come on?? coil pack could still be faulty. have u had engine been steam cleaned??? if so check spark plugs for water
avatar
VXR VIC
Life
Life

Posts : 86
Reputation : 1
Join date : 2009-05-22
Age : 45
Location : north east

Back to top Go down

Re: Help - Please if you can :)

Post by Johnston_888 on Tue Sep 01, 2009 4:47 pm

SRI was only 1.8-1.4 sxi was 1.2-1.3

_________________

Keep the Faith
avatar
Johnston_888
Site Owner & Senior Admin
Site Owner & Senior Admin

Posts : 672
Reputation : 6
Join date : 2009-04-07
Location : Perth, Scotland

http://www.vx-uk.com

Back to top Go down

Re: Help - Please if you can :)

Post by playgirl on Fri Sep 04, 2009 8:57 pm

Johnston_888 wrote:SRI was only 1.8-1.4 sxi was 1.2-1.3

Laughing i said that in my post Razz
avatar
playgirl
Promo Girls
Promo Girls

Posts : 100
Reputation : 3
Join date : 2009-05-06
Location : Hampshire

Back to top Go down

Re: Help - Please if you can :)

Post by tazz666 on Sun Oct 25, 2009 7:44 pm

fuel tank vent valve can cause this aswell as the mass air flow meter
avatar
tazz666
Life
Life

Posts : 73
Reputation : 0
Join date : 2009-10-24
Age : 44

Back to top Go down

Re: Help - Please if you can :)

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum